[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] virsh nodedev-dempxml is not supported by the connection driver



thanks for your reply !
At first ,I use " apt-get install libvirt-bin " to install the libvirt ,the version is 0.8.3 ,and "virsh nodedev-list" works well .
but I need the version 0.9.0. So I complied the libvirt use source code as follows:
#./configure --prefix=/usr --libdir=/usr/lib64 --localstatedir=/var --sysconfdir=/etc
#make
#make install
can you tell me how to complie the libvirt with udev and hal ?

one machine:
qinguan Optiplex-780:~$ dpkg -l | grep udev
ii  libgudev-1.0-0                       164-3                             GObject-based wrapper library for libudev
ii  libudev0                             164-3                             libudev shared library
ii  system-config-printer-udev           1.2.3-3                           Utilities to detect and configure printers automatically
ii  udev                                 164-3                             /dev/ and hotplug management daemon
qinguan Optiplex-780:~$ dpkg -l | grep hal
ii  libhal-storage1                      0.5.14-3                          Hardware Abstraction Layer - shared library for storage devices
ii  libhal1                              0.5.14-3                          Hardware Abstraction Layer - shared library
qinguan Optiplex-780:~$

another machine:
root shahe26:~# dpkg -l | grep udev
ii  libudev0                            164-3                            libudev shared library
ii  udev                                164-3                            /dev/ and hotplug management daemon
root shahe26:~# dpkg -l | grep hal
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
root shahe26:~#

the problem appears in both of two machines above.

best regards,
qinguan

2011/5/9 Osier Yang <jyang redhat com>
于 2011年05月09日 16:02, guan qin 写道:

Hi,

I meet a problem when I use the command "virsh nodedev-dumpxml
pci_0000_00_19_0",it shows as follows:

root shahe26:~# virsh nodedev-list
error: Failed to count node devices
error: this function is not supported by the connection driver:
virNodeNumOfDevices

root shahe26:~# virsh nodedev-dumpxml pci_0000_00_19_0
error: Could not find matching device 'pci_0000_00_19_0'
error: this function is not supported by the connection driver:
virNodeDeviceLookupByName

root shahe26:~# virsh -version
0.9.0
root shahe26:~# virsh net-list
Name                 State      Autostart
-----------------------------------------
default              active     yes
root shahe26:~# virsh list
 Id Name                 State
----------------------------------
root shahe26:~#

I find that only the command "virsh nodedev-? ***" can't work . How can
I solve this problem ? thanks.

best regards,
qinguan


Looks like your libvirt is compiled without "with-udev" and
"with-hal", you need to install the required devel pkgs, and
re-compile.

Regards
Osier


--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]