[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt cannot be built with -Werror on RHEL6RC(x86_64)



On 05/12/2011 05:58 AM, Eric Blake wrote:
> On 05/12/2011 03:55 AM, Wen Congyang wrote:
>> This test program is generated according to gettext.m4.
>> It's a bug of old version gettext, and it's fixed in gettext-0.14.4.
> 
> Unfortunately, there are several other bugs in m4 files inherited as a
> result of our choice of gettext.
> 
>> @@ -1981,7 +1984,7 @@ dnl Enable building libvirtd?
>>  AM_CONDITIONAL([WITH_LIBVIRTD],[test "x$with_libvirtd" = "xyes"])
>>  
>>  dnl Check for gettext
>> -AM_GNU_GETTEXT_VERSION([0.14.1])
>> +AM_GNU_GETTEXT_VERSION([0.14.4])
> 
> But this hunk would likely break out-of-the-box building of libvirt on
> RHEL 5 and CentOS, if they don't have new enough gettext.

I just confirmed that RHEL 5.6 and CentOS now ship with gettext-0.17; as
does the latest cygwin.  We obviously can't go to the latest upstream of
0.18.1.1 because it would alienate several live supported distros, but I
see no point of limiting ourselves to 0.14.x if moving all the way to
0.17 works.  Are any other popular distros stuck on something older than
0.17?

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]