[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Fix netdev detection on RHEL6x versions of qemu



On Tue, 2011-05-24 at 10:10 +0100, Daniel P. Berrange wrote:

> IMHO RHEL specific hacks don't belong in upstream libvirt code.

Currently there are checks against the qemu-kvm RHEL6 help files in the
test system of libvirt, and it is incorrect - as RHEL6 qemu uses netdev,
not add_host.

So why are you testing against the 'RHEL hacked' version of qemu if that
doesn't belong in upstream code? 

Fundamentally if you install an up to date libvirt onto a RHEL6 machine,
the attach-interface code fails as there is no 'add_host' functionality
in the qemu version on that server. RHEL6 qemu uses netdev.

Attach-interface doesn't work when libvirt is compiled on RHEL6. You
have my proposal for fixing it. What is the alternative?

Rgs

NeilW











[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]