[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] [configure] Fix libvirt dependency, and use $VAPIGEN



From: Nirbheek Chauhan <nirbheek gentoo org>

libvirt-0.9.4 is needed for at least VIR_DOMAIN_EVENT_SUSPENDED_RESTORED, etc
from c1ff5dc63dc9d9ec05485bb695cbc66850759ee5 .

$VAPIGEN from AC_PATH_PROG should be used instead of the raw binary `vapigen`
otherwise it's not possible to override the vapigen binary to be used.
---
 configure.ac |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index 0ac7a8f..4f87b37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@ AC_CANONICAL_HOST
 
 AM_SILENT_RULES([yes])
 
-LIBVIRT_REQUIRED=0.5.0
+LIBVIRT_REQUIRED=0.9.4
 GLIB2_REQUIRED=2.10.0
 GOBJECT2_REQUIRED=2.10.0
 GIO_REQUIRED=2.10.0
@@ -217,7 +217,7 @@ if test "x$enable_introspection" = "xyes" ; then
         fi
         if test "x$enable_vala" != "xno" ; then
                 AC_MSG_CHECKING([$VAPIGEN support for --metadatadir])
-                vapigen --help | grep metadatadir 1>/dev/null 2>&1
+                $VAPIGEN --help | grep metadatadir 1>/dev/null 2>&1
                 if test $? != 0 ; then
                         if test "x$enable_vala" == "xcheck" ; then
                                 enable_vala=no
-- 
1.7.3.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]