[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] build failed with warning " failed to load external entity "api.html.tmp"



On Tue, Nov 08, 2011 at 04:33:15PM +0800, Wenyi Gao wrote:
> I got the latest code and build it with following error on Ubuntu 11.10:
> 
> ......
> make  all-am
> make[3]: Entering directory `/home/wayne/workspace/project/libvirt/tools'
>   CC     virsh-console.o
>   CC     virsh-virsh.o
>   CCLD   virsh
>   GEN    virt-xml-validate
>   GEN    virt-pki-validate
> make[3]: Leaving directory `/home/wayne/workspace/project/libvirt/tools'
> make[2]: Leaving directory `/home/wayne/workspace/project/libvirt/tools'
> Making all in docs
> make[2]: Entering directory `/home/wayne/workspace/project/libvirt/docs'
> Validating api.html
> warning: failed to load external entity "api.html.tmp"
> make[2]: *** [api.html] Error 1
> make[2]: Leaving directory `/home/wayne/workspace/project/libvirt/docs'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/wayne/workspace/project/libvirt'
> make: *** [all] Error 2
> 
> 
> I think some dependent packages are missed on my build environment.
> But the error information doesn't show some hint. Does anyone know
> the reason? Thanks.

  Try to get xsltproc and xmllint tools, they are in libxml2 and
libxslt packages, dunno the exact name in Debian/Ubuntu, possibly
some -bin package.

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]