[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] "make rpm" failing with git head on RHEL6



At 11/09/2011 06:52 AM, Eric Blake Write:
> On 11/08/2011 02:37 AM, Justin Clift wrote:
>>
>> Found the problem with the NEWS file.  It's because libxslt wasn't
>> installed.
>>
> 
> Should we be adding libxslt as a maintainer's prereq in bootstrap.conf?
> 
> That is, I think bootstrap.conf should require all packages necessary to

Agree with it. If some packages are not installed in my machine, I will
take some time to find which package is missed. Sometimes I can find it,
but sometimes I can not. It is very useful if bootstrap.conf requires all
packages necessary.

Thanks
Wen Congyang

> create a functional tarball from libvirt.git, even if those packages are
> _not_ required to successfully build an already-available tarball.
> 
>> Still haven't found out the problem with probes.h though.  Now looking at
>> that again.
> 
> On 11/08/2011 01:58 AM, Wen Congyang wrote:
>> I think you do not install this package: systemtap-sdt-devel.
> 
> So that sounds like systemtap is another maintainer prereq.
> 
> 
> On 11/08/2011 04:44 AM, Daniel Veillard wrote:
>> On Tue, Nov 08, 2011 at 04:33:15PM +0800, Wenyi Gao wrote:
>>> I got the latest code and build it with following error on Ubuntu 11.10:
> 
>>> Validating api.html
>>> warning: failed to load external entity "api.html.tmp"
> 
>>    Try to get xsltproc and xmllint tools, they are in libxml2 and
>> libxslt packages, dunno the exact name in Debian/Ubuntu, possibly
>> some -bin package.
> 
> Sounds like xmllint should be yet another maintainer prereq in
> bootstrap.conf.
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]