[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 11/33] Rename virVirtualPortProfileParams & APIs



On 11/03/2011 01:30 PM, Daniel P. Berrange wrote:
From: "Daniel P. Berrange"<berrange redhat com>

Rename the virVirtualPortProfileParams struct to be
virNetDevVPortProfile, and rename the APIs to match
this prefix.

* src/util/network.c, src/util/network.h: Rename port profile
   APIs
* src/conf/domain_conf.c, src/conf/domain_conf.h,
   src/conf/network_conf.c, src/conf/network_conf.h,
   src/network/bridge_driver.c, src/qemu/qemu_hotplug.c,
   src/util/macvtap.c, src/util/macvtap.h: Update for
   renamed APIs/structs
---
  src/conf/domain_conf.c      |   16 +++++++-------
  src/conf/domain_conf.h      |    8 +++---
  src/conf/network_conf.c     |   12 +++++-----
  src/conf/network_conf.h     |    4 +-
  src/libvirt_private.syms    |    6 ++--
  src/network/bridge_driver.c |    6 ++--
  src/qemu/qemu_hotplug.c     |    4 +-
  src/util/macvtap.c          |   36 ++++++++++++++++----------------
  src/util/macvtap.h          |    8 +++---
  src/util/network.c          |   48 +++++++++++++++++++++---------------------
  src/util/network.h          |   33 +++++++++++++++--------------
  11 files changed, 91 insertions(+), 90 deletions(-)

diff --git a/src/util/macvtap.c b/src/util/macvtap.c
index cb13d2b..71243b8 100644
--- a/src/util/macvtap.c
+++ b/src/util/macvtap.c
@@ -89,7 +89,7 @@ VIR_ENUM_IMPL(virMacvtapMode, VIR_MACVTAP_MODE_LAST,
  # define LLDPAD_PID_FILE  "/var/run/lldpad.pid"


-enum virVirtualPortOp {
+enum virNetDevVPortOp {
      ASSOCIATE = 0x1,
      DISASSOCIATE = 0x2,
      PREASSOCIATE = 0x3,


Do you think having such generic names for these enums might lead to a namespace conflict somewhere down the road? Maybe the enum value names could be changed as a part of this patch...


-#endif /* WITH_MACVTAP || WITH_VIRTUALPORT */
+#endif /* WITH_MACVTAP || WITH_NETDEV_VPORT_PROFILE */

WITH_VIRTUALPORT has been changed to WITH_NETDEV_VPORT_PROFILE in this comment, but not in the #ifdef, and the line was completely removed in PATCH 19/33. Since the latter name doesn't appear anywhere in the final result of the series, I think this must be a vestige of something you later decided against, or maybe a search-replace run amok.

ACK aside from that.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]