[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] "make rpm" failing with git head on RHEL6



At 11/09/2011 03:01 PM, Justin Clift Write:
> On 09/11/2011, at 9:52 AM, Eric Blake wrote:
>> On 11/08/2011 02:37 AM, Justin Clift wrote:
>>>
>>> Found the problem with the NEWS file.  It's because libxslt wasn't installed.
>>
>> Should we be adding libxslt as a maintainer's prereq in bootstrap.conf?
>>
>> That is, I think bootstrap.conf should require all packages necessary to create a functional tarball from libvirt.git, even if those packages are _not_ required to successfully build an already-available tarball.
> 
> That sounds like it will fix the problem, pretty much permanently (until further requirements happen).
> 
> Definitely in favour of that. :)
> 
> 
>>> Still haven't found out the problem with probes.h though.  Now looking at
>>> that again.
>>
>> On 11/08/2011 01:58 AM, Wen Congyang wrote:
>>> I think you do not install this package: systemtap-sdt-devel.
>>
>> So that sounds like systemtap is another maintainer prereq.
> 
> It's not the problem.  For me anyway.
> 
> To clarify, systemtap-sdt-devel is already installed.  Doing a brand new autogen.sh, then
> compiling normally with:

I find the following messages from autogen.sh's output:
running CONFIG_SHELL=/bin/sh /bin/sh ./configure --with-dtrace=no --no-create --no-recursion
checking for a BSD-compatible install... /usr/bin/install -c

You have disabled dtrace, so make -j 3 does not fail.

Please run ./configure again, and check whether dtrace is enabled.

Thanks
Wen Congyang

> 
>   make -j 3
> 
> Goes through to successful completion.  All good.
> 
> It's only "make rpm" which is having the problem:
> 
>   make[2]: Entering directory `/home/jc/git_repos/libvirt/src'
>   make[2]: *** No rule to make target `probes.h', needed by `distdir'.  Stop.
>   make[2]: Leaving directory `/home/jc/git_repos/libvirt/src'
>   make[1]: *** [distdir] Error 1
>   make[1]: Leaving directory `/home/jc/git_repos/libvirt'
>   make: *** [rpm] Error 2
> 
> So, it sounds like there's something rpm specific which needs kicking into shape.
> 
> Attaching the full session log file, showing the autogen run, the normal make run,
> and the make rpm run.  Hopefully it helps. :)
> 
> 
> 
> 
> 
> 
> 
> <snip>
>>>> Validating api.html
>>>> warning: failed to load external entity "api.html.tmp"
>>
>>>    Try to get xsltproc and xmllint tools, they are in libxml2 and
>>> libxslt packages, dunno the exact name in Debian/Ubuntu, possibly
>>> some -bin package.
>>
>> Sounds like xmllint should be yet another maintainer prereq in bootstrap.conf.
> 
> Yep, sounds like it. :)
> 
> Regards and best wishes,
> 
> Justin Clift
> 
> --
> Aeolus Community Manager
> http://www.aeolusproject.org
> 
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]