[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] make docs fails on EL5



It seems tit is he same issue as the thread below, the docs can not be generated in some Linux distros.
It may be caused by the incompatibility of document tools in these distros.

http://www.mail-archive.com/libvir-list redhat com/msg47624.html

On 2011-11-16 1:27, Daniel Berteaud wrote:
Hi.

I usually build all the latest libvirt version on EL5 (CentOS x86_64),
and, up to libvirt 0.9.3, I could get it to build without major issue,
but starting with libvirt 0.9.4, I cannot get the rpm to build (I'm
using a quite simple plague/mock setup), I always have this error:

make[2]: Entering directory `/builddir/build/BUILD/libvirt-0.9.7/docs'
   GEN    libvirt-api.xml
   GEN    html/index.html
   GEN    devhelp/index.html
./html/libvirt-virterror.html:613: element a: validity error : ID types
already defined
</h3><pre>#define _virSchedParameter</pre><p></p><h3><a name="types"
id="types"

^
./html/libvirt-virterror.html:843: element a: validity error : ID
functions already defined
</pre></div><h3><a name="functions"
id="functions">Functions</a></h3><h3><a name
                                                   ^
make[2]: *** [html/index.html] Error 4
make[2]: Leaving directory `/builddir/build/BUILD/libvirt-0.9.7/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/libvirt-0.9.7'
make: *** [all] Error 2

Can anybody help me with this ?

Regards, Daniel




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]