[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 12/16] Rename ifaceCheck to virNetDevValidateConfig



On Thu, Nov 17, 2011 at 07:01:52AM -0500, Laine Stump wrote:
> On 11/15/2011 06:14 AM, Daniel P. Berrange wrote:
> >Rename the ifaceCheck method to virNetDevValidateConfig and change
> >so that it always raises an error and returns -1 on error.
> >
> >* src/util/interface.c, src/util/interface.h: Rename ifaceCheck
> >   to virNetDevValidateConfig
> >* src/nwfilter/nwfilter_gentech_driver.c,
> >   src/nwfilter/nwfilter_learnipaddr.c: Update for API rename
> >---
> >  src/libvirt_private.syms               |    2 +-
> >  src/nwfilter/nwfilter_gentech_driver.c |    6 ++-
> >  src/nwfilter/nwfilter_learnipaddr.c    |    6 ++-
> >  src/util/interface.c                   |   83 ++++++++++++++++---------------
> >  src/util/interface.h                   |    5 +-
> >  5 files changed, 55 insertions(+), 47 deletions(-)
> 
> ACK.
> 
> I just noticed that all of these patches rename the functions in
> libvirt_private.syms in place, so when it's all done, the functions
> aren't properly aligned with the .h file they're in, and are no
> longer in alphabetical order. There should be an extra patch ended
> at the end of the series to clean this up.

Yes, I'll clean this up


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]