[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] 'savevm/loadvm' monitor command sequence losing mouse state across a VM restore



On Tue, Nov 22, 2011 at 12:46:26PM -0800, Vincent Passaro wrote:
> All
> 
> eblake on #virt requested that I ask the question here before posting on
> bugzilla, so I wanted to check if anyone has seen this issue.
> 
> I create a vm snapshot (with F16) using virsh snapshot-create
> 
> I then restore the vm with virsh snapshot-restore
> 
> After the restore succeeds I loose the ability to interact with the vm via
> mouse.  Keyboard remains functioning, I can send commands to it via the
> Spice Console (CTRL-DEL), etc.
> 
> I have tired killing X and restarting the machine with no success. To
> restore keyboard functionality I have had to restart libvirtd.

I don't really see how restarting libvirtd affects mouse input, since
the latter is something handled by QEMU. In any case this sounds like
a QEMU bug with not saving/restoring its mouse state correctly. So best
to ask this kind of question on the qemu mailing list.


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]