[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] All virsh commands testing failed with git head



On Tue, Nov 29, 2011 at 06:59:46PM +0800, Osier Yang wrote:
> On 2011年11月29日 18:55, Daniel Veillard wrote:
> >On Tue, Nov 29, 2011 at 06:46:26PM +0800, Osier Yang wrote:
> >>Part of the error log is pasted, looks like it's caused by
> >>the calling of virNodeSuspendInit in virInitialize.
> >>================================
> >
> >   Weird that worked for me , lemme recheck that everything went in ...
> >
> >>cd tests; LIBVIRT_DEBUG=1 VIR_TEST_DEBUG=1 ./virshtest; cd -
> >>TEST: virshtest
> >>  1) virsh list (default)                                              ...
> >>Offset 0
> >>Expect [ ]
> >>Actual [2011-11-29 18:44:38.153: 24448: info : libvirt version: 0.9.7
> >>2011-11-29 18:44:38.153: 24448: error : virNodeSuspendInit:86 :
> >>Failed to get host power management features
> >>  ]
> >
> >   Are you running the tests as root ?
> >If no, that's weird
> >If yes, do you have pm-utils package installed ?
> 
> Yes, as root, and pm-utils installed.
> 
> [root foo libvirt]# pm-is-supported --suspend
> [root foo libvirt]# echo $?
> 0


I know what's going wrong here & am working on the fix


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]