[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 06/14] Rename suspend capabilities APIs

On 11/29/2011 09:53 PM, Eric Blake wrote:

> On 11/29/2011 09:19 AM, Srivatsa S. Bhat wrote:
>>>  /**
>>> - * virGetPMCapabilities:
>>> + * virNodeSuspendGetTargetMask:
>>>   *
>>>   * Get the Power Management Capabilities that the host system supports,
>>>   * such as Suspend-to-RAM (S3), Suspend-to-Disk (S4) and Hybrid-Suspend
>>>   * (a combination of S3 and S4).
>>>   *
>> You might want to remove the terminology "S3", "S4" etc from here, perhaps?
> Nah.  While we don't want the public XML or enum names to reflect an
> x86-specific naming convention, there's nothing wrong with internal APIs
> using terminology in comments to make it easier to correlate the generic
> name with the specific feature, so that developers familiar with either
> term can be sure to understand.

Ok, that sounds good. So lets retain it then.

Srivatsa S. Bhat
IBM Linux Technology Center

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]