[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] hugepages error: "hugetlbfs filesystem is not mounted"



On Mon, Oct 03, 2011 at 01:09:31PM +0200, Shahar Havivi wrote:
> Hi,
> 
> I am trying to run a VM (via VDSM) with hugepages and I am getting this error:
> "virNetClientProgramDispatchError:170 : internal error hugetlbfs filesystem is not mounted"
> 
> 
> hugepages is mounted with the proper permissions (36:36) in case of vdsm user,
> this code use to work..., now I am at version: libvirt-0.9.4-12.el6.x86_64
> 
> output of few commands:
> 
> # tree /dev/hugepages/
> /dev/hugepages/
> `-- libvirt
>     `-- qemu
> 
> # ll -n /dev/hugepages/libvirt/
> total 0
> drwxr-xr-x 2 36 36 0 Oct  3 12:46 qemu/

The user ID  '36:36' looks a little bit strange. Did you set that
yourself ?  When libvirtd starts up, it should detect the mount
point and then create the $MOUNT/libvirt/qemu directory itself,
setting up the correct userid/groupid which i'd expect to be 
107:107 on Fedora/Rhel

In addition, was the hugetlbfs mount point actually mounted at
the time libvirtd was started up ?  If you mount hugetlbfs after
starting libvirtd, you will need to restart it to enable hugetlbs
in libvirtd.

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]