[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] RPM build failure on Redhat6



于 2011-10-11 16:19, Wen Congyang 写道:
At 10/11/2011 04:07 PM, Wayne Xia Write:
于 2011-10-1 5:08, Eric Blake 写道:
On 09/28/2011 10:48 PM, Wayne Xia wrote:
Hi, I want to build rpm for latest libvit version on Redhat6, but when
I type:
./autogen.sh --system
make rpm -j4

error happens:

sitemap.html.tmp index.html.tmp archdomain.html.tmp downloads.html.tmp
auth.html.tmp internals/locking.html.tmp archnode.html.tmp
hvsupport.html.tmp bugs.html.tmp java.html.tmp locking.html.tmp
logging.html.tmp testapi.html.tmp formatnetwork.html.tmp
bindings.html.tmp uri.html.tmp drvtest.html.tmp contact.html.tmp
formatnwfilter.html.tmp intro.html.tmp drvxen.html.tmp drvesx.html.tmp
drvqemu.html.tmp drvvmware.html.tmp testsuites.html.tmp
devguide.html.tmp firewall.html.tmp architecture.html.tmp todo.html.tmp
formatsnapshot.html.tmp formatstorage.html.tmp deployment.html.tmp
internals.html.tmp api_extension.html.tmp drvuml.html.tmp
virshcmdref.html.tmp csharp.html.tmp python.html.tmp drvremote.html.tmp
archstorage.html.tmp remote.html.tmp drivers.html.tmp
formatnode.html.tmp
make[2]: Leaving directory
`/home/xiawenc/WorkDir/Source/libvirt/libvirt/docs'
make[1]: *** [distdir] Error 1

That's not the actual error (which happened several lines before where
you started pasting).

I'm not sure what's going on, but I will add that I have sometimes seen
a 'make -j2' failure when the makefile gets to the point of generating
todo.html. I'm not sure where the missing make dependency is, but
hopefully next time someone sees it, and accurately reports it, we can
patch docs/Makefile.am to avoid these parallel make problems.

In the meantime, 'make -C docs' without -j should get you past this
issue.

Thanks for the information. I tried to use command make rpm and make -C
docs, but it did not work, some error pops like following:

  make[2]: Entering directory
`/home/xiawenc/WorkDir/Source/libvirt/libvirt/docs'
Generating api.html.tmp
missing XHTML1 DTD
Generating api_extension.html.tmp
missing XHTML1 DTD

I guess you miss the package xhtml1-dtds.

Thanks
Wen Congyang

it is the cause of the problem, many thanks


complete records after command "make rpm" is in the attachment, I am not
sure how to find the clue to solve the problem.



--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list



--
Best Regards

Wayne Xia
mail:xiawenc linux vnet ibm com
tel:86-010-82450803


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]