[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Compiler warnings



Eric,
# rpm -q gcc
gcc-4.4.6-3.el6.x86_64

Regards,
Alex

----- Original Message -----
From: "Eric Blake" <eblake redhat com>
To: "Alex Jia" <ajia redhat com>
Cc: libvir-list redhat com
Sent: Monday, October 17, 2011 11:38:50 PM
Subject: Re: [libvirt]  Compiler warnings

On 10/17/2011 09:35 AM, Alex Jia wrote:
> Hi all,
> I meet the following compiler warnings today:
> ......
>    CC     libvirt_util_la-buf.lo
> util/buf.c: In function 'virBufferEscape':
> util/buf.c:430: warning: logical '&&' with non-zero constant will always
> evaluate as true [-Wlogical-op]

Which version of gcc?

>
> Has anybody the same experience?

Not with gcc 4.5.1 (Fedora 14), but not the first time that newer gcc 
has become smarter.  I'll patch it if I can reproduce it (I'll try a 
rawhide build shortly).

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]