[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 0/7] Update systemtap probing

Tested by:Royce Lv<lvroyce linux vnet ibm com>

I'm not sure whether I encountered are env/config related problem or bugs,so I submit my installation process here for you to reference.

1.env description:
    host os:Ubuntu 11.04(kernel 2.6.38-8-generic,x86_64)
    dtrace:sun D 1.6
    systemtap:version 1.3/0.148 non-git sources

2.install systemtaped libvirt
    ./configure --prefix=/usr --with-dtrace

dtrace: failed to compile script probes.d: line 2: invalid control directive: #file:
    delete lines begin with "#"

    Invoking: ld -o probes.o -r probes.tmp.o /usr/lib/dtrace/drti.o
ld: i386 architecture of input file `probes.tmp.o' is incompatible with i386:x86-64 output dtrace: failed to link script probes.d: failed to link probes.o: ld exited with status 1
    ????so the script incompatible for 64 system,is it a bug?
    change "DTRACE=/usr/bin/dtrace" to "DTRACE=/usr/bin/dtrace -64"

    -->error3:(with ./configure --prefix=/usr --enable-dtrace)
    *** objects  probes.o is not portable!
/usr/bin/ld: probes.o: relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompile with -fPIC
    probes.o: could not read symbols: Bad value
    (1)reconfig with
        ./configure --with-dtrace --disable-share
compile success,but libvirt_probes.stp size is 0,stp script can't be used
    (2)add flags with -fPIC
        nothing changed,still the same error
    (3)tried configure --with-pic
        nothing changed,still the same error

3.Here is my question:
    (1)Is the system-enabled libvirt support 64bit system?
    (2)Do you have suggestion about error3?

Sorry to bother you so many times,But I do think applying these patches are important and useful for future debugging.Thank you for your time!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]