[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [RFC PATCH 0/8 v2] Summary on block IO throttle



On 10/28/2011 02:59 AM, Lei Li wrote:
Given that the XML is named <iotune> under <disk>, we should probably
name the virsh command 'blkiotune' or 'disk-iotune', not 'blkiothrottle'.

Hi Eric, we used<iothrottle> first, I changed it since Daniel P. Berrange
proposed<iotune> for per-disk element instead of<iothrottle> when we
discussed at RFC V1.

The command 'blkiotune' already exist, supported the cgroups
blkio-controller, which handles proportional shares and throughput/iops
limits on host block devices, global to the domain, but blkio throttling
is specified per-disk and can vary across multiple disks. They are
different
two mechanism.

So how about use<iothrottle> again? :)

For extensibility, I _don't_ want to hardcode 'throttle' into the name; the goal here is that we want this xml element to contain all tuning parameters that are appropriate for a single disk, which could be more than just throttling. So using 'virsh disk-iotune' sounds like the best name for the virsh side of the command.

--
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]