[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Fix URL-escaping for domainDefine



On Fri, Sep 09, 2011 at 03:22:42PM +0800, Daniel Veillard wrote:
> On Thu, Sep 08, 2011 at 04:34:10PM +0200, Philipp Hahn wrote:
> > '+' in strings get translated to ' ' when editing domains.
> > While xenDaemonDomainCreateXML() did URL-escape the sexpr,
> > xenDaemonDomainDefineXML() did not.
> > 
> > Remove the explicit urlencode() in xenDaemonDomainCreateXML() and add
> > the direct encoding calls to xend_op_ext() because it calls xend_post()
> > which uses "Content-Type: application/x-www-form-urlencoded". According
> > to <http://www.w3.org/TR/html4/interact/forms.html#h-17.13.4.1> this
> > requires all parameters to be url-encoded as specified in rfc1738.
> > 
> > Notice: virBufferAsprintf(..., "%s=%s", ...) is again replaced by three
> > calls to virBufferURIEncodeString() and virBufferAddChar() because '='
> > is a "reserved" character, which would get escaped by
> > virBufferURIEncodeString(), which - by the way - escapes anything not
> > c_isalnum().
> 
>   ACK, interesting cleanup too :-)

  BTW, I pushed it

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]