[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] virsh: Use old API if remote libvirtd does not support new



On 09/13/2011 04:50 PM, Eric Blake wrote:
On 09/13/2011 09:16 AM, Peter Krempa wrote:
Commit ffe28ab74b821c916ec4ba8efb5c992454e4bd24 introduced regression
while comunicating with older libvirtd command 'domblkstat' used the new

s/comunicating/communicationg/

API and did not check for VIR_ERR_RPC error code signalling the remote
server does not support this API and did not fall back to older API.
Thereafter 'domblkstat' ended with "error: unknown procedure: 243".
---

ACK.

footnote: Will not apply along with:
[libvirt] [PATCH v5] virsh: Add more human-friendly output of
domblkstat command
as that path does fix this bug.

Apply this first, then rebase that patch into a v6.

This patch is now pushed.

--
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]