[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH 2/2] Revert "virsh: Use old API if remote libvirtd does not support new"



This reverts commit 799912fa05b8c3aa37bd04c57b196755f3f70552; now
that the rpc regression is fixed, virsh no longer needs the special
case here.
---
 tools/virsh.c |    3 +--
 1 files changed, 1 insertions(+), 2 deletions(-)

diff --git a/tools/virsh.c b/tools/virsh.c
index 3c6e65a..aee1842 100644
--- a/tools/virsh.c
+++ b/tools/virsh.c
@@ -1090,8 +1090,7 @@ cmdDomblkstat (vshControl *ctl, const vshCmd *cmd)
      * then.
      */
     if (rc < 0) {
-        if (last_error->code != VIR_ERR_NO_SUPPORT &&
-            last_error->code != VIR_ERR_RPC) {
+        if (last_error->code != VIR_ERR_NO_SUPPORT) {
             virshReportError(ctl);
             goto cleanup;
         } else {
-- 
1.7.4.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]