[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] qemu: Relax -no-shutdown check to [0.14.0, 0.15.50)



SIGTERM handling for -no-shutdown is already fixed in qemu git and
libvirt can safely use it. The downside is that 0.15.50 version of qemu
can be any qemu compiled from git, even that without the fix for
SIGTERM. However, I think this patch is worth it since someone using
qemu from git should expect their data can get corrupted and excluding
0.15.50 from the check makes testing current qemu with libvirt much
easier.
---
 src/qemu/qemu_capabilities.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c
index 8e20e3f..4325f77 100644
--- a/src/qemu/qemu_capabilities.c
+++ b/src/qemu/qemu_capabilities.c
@@ -1017,9 +1017,9 @@ qemuCapsComputeCmdFlags(const char *help,
 
     /* Do not use -no-shutdown if qemu doesn't support it or SIGTERM handling
      * is most likely buggy when used with -no-shutdown (which applies for qemu
-     * 0.14.* and 0.15.*)
+     * 0.14.* and <0.15.50)
      */
-    if (strstr(help, "-no-shutdown") && (version < 14000 || version > 15999))
+    if (strstr(help, "-no-shutdown") && (version < 14000 || version >= 15050))
         qemuCapsSet(flags, QEMU_CAPS_NO_SHUTDOWN);
 
     /*
-- 
1.7.6.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]