[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] cgroup cpuset limited by default?



On 04/16/2012 05:34 PM, Marc-André Lureau wrote:

> Hi,
> 
> I noticed recently that my system VMs feel much slower, and that seems
> to be because of cpuset cgroup which constrain the VM on the first
> cpu. This doesn't happen with session VMs, since they are not ruled by
> cgroup. I run f17 with libvirt git, the VMs are created with
> virt-manager, using mostly default settings
> 
>  <vcpu>4</vcpu>
> <os>
>    <type arch='x86_64' machine='pc-0.15'>hvm</type>
>    <boot dev='hd'/>
>  </os>
>  <features>
>    <acpi/>
>    <apic/>
>    <pae/>
>  </features>
>  <clock offset='localtime'/>
> 
> Is that intended or is it a bug?
> 


Did you happen to perform a suspend/resume or a hibernation/restore
on your computer? (Or did you do CPU hotplug manually?)

If yes, you might be seeing the problem reported at:
https://bugzilla.redhat.com/show_bug.cgi?id=714271

Unfortunately, as of now the kernel still doesn't handle this
properly.. IOW, we don't have a kernel fix (yet).

Regards,
Srivatsa S. Bhat
IBM Linux Technology Center


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]