[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCHv5 02/23] qemu: use consistent error when qemu binary is too old



On Mon, Apr 16, 2012 at 23:05:53 -0600, Eric Blake wrote:
> Most of our errors complaining about an inability to support a
> particular action due to qemu limitations used CONFIG_UNSUPPORTED,
> but we had a few outliers.  Reported by Jiri Denemark.
> 
> * src/qemu/qemu_command.c (qemuBuildDriveDevStr): Prefer
> CONFIG_UNSUPPORTED.
> * src/qemu/qemu_driver.c (qemuDomainReboot)
> (qemuDomainBlockJobImpl): Likewise.
> * src/qemu/qemu_hotplug.c (qemuDomainAttachPciControllerDevice):
> Likewise.
> * src/qemu/qemu_monitor.c (qemuMonitorTransaction)
> (qemuMonitorBlockJob, qemuMonitorSystemWakeup): Likewise.
> ---
> 
> v5: new patch, factored out from comments on other patches
> 
>  src/qemu/qemu_command.c |    2 +-
>  src/qemu/qemu_driver.c  |   13 ++++++++-----
>  src/qemu/qemu_hotplug.c |    2 +-
>  src/qemu/qemu_monitor.c |    6 +++---
>  4 files changed, 13 insertions(+), 10 deletions(-)

Also independent, ACK.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]