[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [test-API 12/17] Substitute 'guest"' with 'domain"'



On 2012年04月23日 15:40, Peter Krempa wrote:
On 04/20/2012 08:46 AM, Osier Yang wrote:
% for i in $(grep 'guest"' * -r | awk -F':' '{print $1}'| uniq); do \
sed -i -e 's/guest"/domain"/g' $i; \
done

This also affects the codes like:

- url = global_parser.get_value("guest", gname + "src")
- dict['kickstart'] = global_parser.get_value("guest", gname + "ks")
+ url = global_parser.get_value("domain", gname + "src")
+ dict['kickstart'] = global_parser.get_value("domain", gname + "ks")

A follow up patch will change the property 'guest' into 'domain'
---

I don't like this very much. "Domain" is a XEN term. IMHO "guest" is
more universal and is a little more specific. (It's harder to
distinguish Xen's Dom0 vs DomU than "host" and "guest")


Yeah, I'd guess it's just caused by XEN is the first hypervisor libvirt
supported, and as a history reason, it's used till now.

Agree that "guest" is better here, but in many other places, "domain"
is better. The problem is there was not a routine for test-API to
follow (even no for libvirt I guess), and the two terms were used
as the coders willing. Actually I found the problem ("guest" is better
in some place) when creating the patch, but I don't have a idea to do it automatically, doing manually though the project will take much
time.

Osier


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]