[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: Fix version of gettext macros



On 04/24/2012 06:52 AM, Daniel P. Berrange wrote:
> On Tue, Apr 24, 2012 at 06:22:44AM -0600, Eric Blake wrote:
>> On 04/24/2012 03:50 AM, Peter Krempa wrote:
>>> Commit c9cd419caba9effa11ca53e8696e5f6a4b424d60 added copying of the
>>> makefile for translation files from gnulib. The makefile from gnulib is
>>> of version 0.18 but the build configuration cretes macros from version
>>> 0.17 which breaks the build with message:
>>>
>>> *** error: gettext infrastructure mismatch: using a Makefile.in.in from
>>> gettext version 0.18 but the autoconf macros are from gettext version
>>> 0.17
>>> ---
>>>  bootstrap.conf |    2 +-
>>>  configure.ac   |    2 +-
>>>  2 files changed, 2 insertions(+), 2 deletions(-)
>>
>> NACK.  RHEL 5 still uses gettext 0.17, and this breaks the build there.
>>
>> We need to fix gnulib to not force us to use gettext 0.18.  I'll look
>> into this.
> 
> Can we just remote the change Peter mentiones above that cause this to
> break in the first place ?  It doesn't seem right to me, to be using
> gnulib's makefile for the po/ dir, instead of the one our gettext
> actually desires.

Yep, I'm working on it, but it involves a change to upstream gnulib to
make bootstrap not forcefully override our desired versions.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]