[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v2] qemu_agent: Report error class at least



On 28.04.2012 09:38, Osier Yang wrote:
> On 2012年04月12日 22:37, Michal Privoznik wrote:
>> Currently, qemu GA is not providing 'desc' field for errors like
>> we are used to from qemu monitor. Therefore, we fall back to this
>> general 'unknown error' string. However, GA is reporting 'class' which
>> is not perfect, but much more helpful than generic error string.
>> Thus we should fall back to class firstly and if even no class
>> is presented, then we can fall back to that generic string.
>>
>> Before this patch:
>> virsh # dompmsuspend --target mem f16
>> error: Domain f16 could not be suspended
>> error: internal error unable to execute QEMU command
>> 'guest-suspend-ram': unknown QEMU command error
>>
>> After this patch:
>> virsh # dompmsuspend --target mem f16
>> error: Domain f16 could not be suspended
>> error: internal error unable to execute QEMU command
>> 'guest-suspend-ram': The command has not been found
>> ---
>>   src/qemu/qemu_agent.c |   37 +++++++++++++++++++++++++++++++++++--
>>   1 files changed, 35 insertions(+), 2 deletions(-)
>>

> 
> Makes sense, and ACK.
> 
> Regards,
> Osier

Thanks, pushed.

Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]