[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] fix error on loading libvirt_driver_qemu.so



On Thu, Aug 02, 2012 at 15:28:44 +0800, Hu Tao wrote:
> When start up libvirtd, it gives error like this(wrapped):
> 
> 2012-08-02 06:59:03.414+0000: 5463: error :
>   virDriverLoadModule:78 : failed to load module
>   /usr/lib64/libvirt/connection-driver/libvirt_driver_qemu.so
>   /usr/lib64/libvirt/connection-driver/libvirt_driver_qemu.so:
>   undefined symbol: virSecurityManagerGetProcessLabel
> 2012-08-02 06:59:03.415+0000: 5463: error :
>   virDriverLoadModule:78 : failed to load module
>   /usr/lib64/libvirt/connection-driver/libvirt_driver_lxc.so
>   /usr/lib64/libvirt/connection-driver/libvirt_driver_lxc.so:
>   undefined symbol: virSecurityManagerGetProcessLabel
> 
> This patch fixes the problem.
> 
> ---
>  src/Makefile.am |    3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/src/Makefile.am b/src/Makefile.am
> index b48ce65..c8f3e18 100644
> --- a/src/Makefile.am
> +++ b/src/Makefile.am
> @@ -831,7 +831,8 @@ endif
>  if WITH_QEMU
>  noinst_LTLIBRARIES += libvirt_driver_qemu_impl.la
>  libvirt_driver_qemu_la_SOURCES =
> -libvirt_driver_qemu_la_LIBADD = libvirt_driver_qemu_impl.la
> +libvirt_driver_qemu_la_LIBADD = libvirt_driver_qemu_impl.la \
> +                                libvirt_driver_security.la
>  if WITH_DRIVER_MODULES
>  mod_LTLIBRARIES += libvirt_driver_qemu.la
>  libvirt_driver_qemu_la_LIBADD += ../gnulib/lib/libgnu.la

NACK, the security driver needs to linked directly into libvirtd. I tried to
fix this with my recent patch but it only worked when libvirt is built
without driver modules. I'll prepare a new patch to really fix this issue.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]