[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 0/2] Add lsi and virtio-scsi qemu caps



On 08/07/2012 07:37 PM, Daniel P. Berrange wrote:
On Tue, Aug 07, 2012 at 02:54:33PM +0800, Guannan Ren wrote:
On qemu-kvm-0.15.1, it supports only lsi scsi controller model.
On qemu-kvm-0.12.1.2, it supports only virtio-scsi-pci scsi model
This doesn't make sense.  virtio-scsi did not exist until long
after qemu-kvm-0.12.1.2.

     This is the version on my RHEL6.3 , maybe not upstream version code.
     # rpm -qa|grep kvm
       qemu-kvm-0.12.1.2-2.302.el6.x86_64

     # /usr/libexec/qemu-kvm --version
      QEMU PC emulator version 0.12.1 (qemu-kvm-0.12.1.2)


On qemu 1.1.50, it supports both.
So, instead of using the lsilogic model by default, the patch tries
to check which model the current QEMU supports, then choose it, lsi
has the priority.
I'm not convinced we should ever be trying to use virtio scsi by
default, given its wide lack of guest support. If LSI scsi does
not exist, just report an error IMHO, and let virtio scsi require
an explicit config choice.

       Get it. the virtio-scsi is not used widely.
       Thanks for the review.

       Guannan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]