[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] error: authentication failed: TRANSPORT_FAULT



Trying to build 0.9.13 on XenServer6.0. Stucked with below things


1. I could not manage to solve below dependency problem. So edited libvirt.spec to by pass this.

# rpmbuild -bb libvirt.spec 
error: Failed build dependencies:
device-mapper-devel is needed by libvirt-0.9.13-1.i386
libwsman-devel >= 2.2.3 is needed by libvirt-0.9.13-1.i386
libblkid-devel >= 2.17 is needed by libvirt-0.9.13-1.i386


2. "make check" is bypassed since below checks where failing.
TEST: viruritest
      ...........!....!.                       18  FAIL
FAIL: viruritest
TEST: interfaceschematest
      ..!.!!!!..........                       18  FAILED
FAIL: interfaceschematest
TEST: nwfilterschematest
      ......!..........................!...... 40 
      .                                        41  FAILED
FAIL: nwfilterschematest


3. rpmbuild -bb libvirt.spec

  RPM build errors:
    File not found: /var/tmp/libvirt-0.9.13-1-root/etc/rc.d/init.d/libvirtd
    File must begin with "/": rm
    File must begin with "/": -f
    File must begin with "/": $RPM_BUILD_ROOT/etc/sysctl.d/libvirtd
    File not found: /var/tmp/libvirt-0.9.13-1-root/var/log/libvirt/libxl
    File not found: /var/tmp/libvirt-0.9.13-1-root/etc/libvirt/lxc.conf
    File not found: /var/tmp/libvirt-0.9.13-1-root/var/run/libvirt/lxc
    File not found: /var/tmp/libvirt-0.9.13-1-root/var/lib/libvirt/lxc
    File not found: /var/tmp/libvirt-0.9.13-1-root/var/run/libvirt/libxl
    File not found: /var/tmp/libvirt-0.9.13-1-root/var/lib/libvirt/libxl
    File not found: /var/tmp/libvirt-0.9.13-1-root/usr/share/augeas/lenses/libvirtd_lxc.aug
    File not found: /var/tmp/libvirt-0.9.13-1-root/usr/share/augeas/lenses/tests/test_libvirtd_lxc.aug
    File not found: /var/tmp/libvirt-0.9.13-1-root/usr/libexec/libvirt_lxc
    File not found: /var/tmp/libvirt-0.9.13-1-root/usr/libexec/libvirt_parthelper
    File not found: /var/tmp/libvirt-0.9.13-1-root/usr/lib/libvirt/connection-driver/libvirt_driver_lxc.so
    File not found: /var/tmp/libvirt-0.9.13-1-root/usr/lib/libvirt/connection-driver/libvirt_driver_libxl.so



[root localhost SPECS]# cat /proc/version 
Linux version 2.6.32.12-0.7.1.xs5.6.100.307.170586xen (geeko buildhost) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Tue Nov 30 09:55:20 EST 2010


Any idea ?


Arun





On Thu, Aug 9, 2012 at 12:28 AM, Eric Blake <eblake redhat com> wrote:
On 08/08/2012 11:25 AM, Arun Sharma wrote:
> Hello
>
> Getting below error while connecting with XenServer using virsh. I have
> builded libvirt version 0.9.3 (--with-xenapi) from tar file and installed
> on Xen 5.6 FP1.

If you're going to build your own libvirt anyway, can you try again with
0.9.13 or even libvirt.git instead of 0.9.3?  It would be nice to know
if the problem has been fixed in the meantime.

--
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org




--
Regards
Arun Sharma
09987668884


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]