[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: fix binary location in stap files --with-driver-modules



On Fri, Aug 10, 2012 at 05:29:54PM -0400, Laine Stump wrote:
> libvirt_qemu_probes.stp stopped working after switching to a build
> that used --with-driver-modules. This was because the symbols listed
> int libvirt_qemu_probes.stp are no longer in $(bindir)/libvirtd, but
> are now in $(libdir)/connection-driver/libvirt_driver_qemu.so.
> 
> This patch enhances dtrace2systemtap.pl (which generates the .stp
> files from .d files) to look for a new "module" setting in the
> comments of the .d file (similar to the existing "binary" setting),
> and to look for a --with-modules option. If the --with-modules option
> is set *and* a "module" setting is present in the .d file, the process
> name for the stap line is set to
> 
>    $libdir/$module
> 
> If either of these isn't true, it reverts to the old behavior.
> 
> src/Makefile.am was also modified to add the --with-modules option
> when the build calls for it, and src/libvirt_qemu_probes.d has added a
> "module" line pointing to the correct .so file for the qemu driver.
> ---
>  src/Makefile.am           |  7 +++++--
>  src/dtrace2systemtap.pl   | 12 ++++++++++++
>  src/libvirt_qemu_probes.d |  1 +
>  3 files changed, 18 insertions(+), 2 deletions(-)

ACK, thanks for fixing this.

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]