[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] building on RHEL 5 currently broken



On 08/21/2012 04:50 PM, Eric Blake wrote:
> On 08/20/2012 05:54 PM, Eric Blake wrote:
>> Just a quick heads-up (I'll fix it later, when I have more time): I just
>> learned commit 350583c85 broke builds on RHEL 5, because of the use of
>> AS_VERSION_COMPARE in configure.ac which was not available in older
>> autoconf 2.59.
> It turned into six patches, but I can now run 'make check', with these
> results:
>
>
> TEST: interfaceschematest
>       ..!.!!!!..........                       18  FAILED

interfaceschematest is meaningless for RHEL5, since actually using the
virInterface API requires netcf, and netcf was never an official part of
RHEL5 (although there was a package in EPEL, at some point fairly early
on support was discontinued because of some other dependent package
missing in RHEL5; a proper version of libnl maybe? I've forgotten...)

> FAIL: interfaceschematest
>
> TEST: nwfilterschematest
>       ......!..........................!...... 40
>       .                                        41  FAILED
> FAIL: nwfilterschematest
>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]