[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] Fix a missing build requirement on dbus-devel



Communication with the firewall daemon uses DBus
so if we compile with firewalld support, the dbus-devel
is required for building

pushed under build breaker rules

diff --git a/libvirt.spec.in b/libvirt.spec.in
index ea2fd88..18a7fb8 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -521,6 +521,11 @@ BuildRequires: util-linux
 BuildRequires: nfs-utils
 %endif
 
+%if %{with_firewalld}
+# Communication with the firewall daemon uses DBus
+BuildRequires: dbus-devel
+%endif
+
 # Fedora build root suckage
 BuildRequires: gawk
 

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]