[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Entering freeze for libvirt-0.10.0



On 08/24/2012 01:54 PM, Laine Stump wrote:
>>> Thomas, do you have any info on the libnl version used in Ubuntu 10.04,
>>> and/or what might be the cause of this warning.
>> It's a static inline which I guess is the problem here. Laine, you
>> are probably using a libnl version which does not include the commit
>> below.
> 
> I'm using libnl-devel-1.1-15.fc17.x86_64
> 
> For fun, I just installed libnl3-devel (which has the inlined
> nl_object_priv(), reconfigured to switch to using libnl3, and it also
> compiled without problems on F17. So I guess it's completely related to
> the gcc version.

Not just the gcc version, but _how_ the function is declared.  'static
inline' is okay, 'extern inline' without a later body is where you run
into problems.  The bug exists in older libnl headers, and has been
fixed upstream for libnl3; but while Fedora 17 ships libnl with a
patched header, Ubuntu 10.04 did not.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]