[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] specfile: require libnl3 for Fedora >= 18 and RHEL >= 7



On 08/24/2012 06:04 PM, Eric Blake wrote:
> On 08/24/2012 03:57 PM, Laine Stump wrote:
>> Everything is ready in both netcf and libvirt to switch over to libnl3
>> in future releases of both Fedora and RHEL. This needs to be done more
>> or less simultaneously in both packages, though, because you can't mix
>> libnl1.1 and libnl3 in the same process (e.g. libvirtd using
>> libnl-3.so and libnetcf.so, while libnetcf.so uses libnl.so)
>>
>> This patch does two things when fedora >= 18 || rhel >= 7):
>>
>>   1) requires libnl3-devel
>>   2) requires netcf-devel-0.2.2 or greater
>>
>> (the idea is that a similar patch is going into netcf's specfile, so
>> that when a build of netcf is done on F18 or later (or RHEL7 or later)
>> netcf will be guaranteed to be built with libnl3 rather than
>> libnl-1.1)
>> ---
>>  libvirt.spec.in | 9 +++++++++
>>  1 file changed, 9 insertions(+)
> Makes sense - you have my ACK from a review standpoint, although I'd at
> least like to test a build against the netcf package from F18
> updates-testing if we have time to do that before DV cuts the 0.10.0
> release.
>
>> +
>>  %if %{with_netcf}
>> +%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
>> +BuildRequires: netcf-devel >= 0.2.2
>> +%else
>>  %if 0%{?fedora} >= 16 || 0%{?rhel} >= 6
>>  BuildRequires: netcf-devel >= 0.1.8
> Question - should we _also_ be stating that on F17, netcf must be less
> than 0.2.2?  

Not necessary, because any netcf built on F17 will always be built with
libnl1. (as long as you're doing an rpm build using the specfile; and if
you're not using the specfile, then nothing you put in the specfile will
help you :-)


> I don't know if the specfile format allows you to specify a
> version window, or if it even makes sense (I'm guessing that 'yum
> update' will detect the .so conflict even if we don't specify a maximum
> version, if you try to rebuild too-new netcf on an older Fedora).

Even if we were to update netcf to 0.2.2 on F17, the specfile would
still ensure that the proper libnl would be built. (To make sure that's
the case even if you have both libnl-devels installed, I added a small
bit to netcf's specfile after your review that forces configure to be
run with --with-libnl1 on F17/RHE6.x and previous)

>   So I
> don't think this comment requires you to make any changes.
>

Thanks. I'm not pushing yet - first the proper netcf build has to be in
place.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]