[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/1] Fix adding ports to OVS bridges without VLAN tags



On Aug 30, 2012, at 3:31 PM, Eric Blake wrote:

> On 08/30/2012 11:53 AM, Kyle Mestery wrote:
>> The introduction of the new VLAN code, along with the fix
>> from 5e465df6be8bcb00f0b4bff831e91f4042fae272, caused the
>> addition of OVS ports to fail with the following message:
>> 
>> ovs-vsctl: 00002|vsctl|ERR|: missing column name
>> 
>> This fix takes into account the VLAN arguments are optional,
>> and correctly sets up the command line to run the "ovs-vsctl"
>> command to add ports to the OVS bridge.
>> 
>> Signed-off-by: Kyle Mestery <kmestery cisco com>
>> ---
>> src/util/virnetdevopenvswitch.c | 13 +++++++++----
>> 1 file changed, 9 insertions(+), 4 deletions(-)
>> 
>> diff --git a/src/util/virnetdevopenvswitch.c b/src/util/virnetdevopenvswitch.c
>> index 00271a0..fcf6d91 100644
>> --- a/src/util/virnetdevopenvswitch.c
>> +++ b/src/util/virnetdevopenvswitch.c
>> @@ -104,9 +104,15 @@ int virNetDevOpenvswitchAddPort(const char *brname, const char *ifname,
>>     }
>> 
> 
>> +    if (virBufferCurrentContent(&buf) != "")
> 
> Won't work.  The address of "" is not constant.  Instead, you want to
> probe virBufferUse() for being non-zero.
> 
Thanks Eric, I'll generate a new patch now and send it out.

Kyle

> -- 
> Eric Blake   eblake redhat com    +1-919-301-3266
> Libvirt virtualization library http://libvirt.org
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]