[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirtd crash upon virsh destroy



On Tue, Dec 04, 2012 at 10:38:07AM -0500, Scott Sullivan wrote:
> Running libvirt v1.0.0, with
> f0e72b2f5c675f927d04545dc5095f9e5998f171 applied. The problem (which
> I cannot reproduce reliably), is that libvirtd crashes sometimes on
> a destroy (sequence of events and crash log below).
> 
> I was wondering if anyone had any insights as to the cause of this
> crash, or even if any commits after v1.0.0 might address this. If I
> can provide anymore information to help debug this I would be happy
> to try and provide it. At the time of this crash, the instance being
> destroyed did not have any RBD attachments, it was just running off
> its local LVM.
> 
> Sequence of events:
> 
> 1.) virsh destroy ID
> End of file while reading data: Input/output error ; error: Failed
> to reconnect to the hypervisor
> 
> (libvirtd at this point has crashed)

if you are able to reproduce this reasonably easily, it would be nice
if you could capture a stack trace with GDB.  eg "thread apply all bt"
from a GDB prompt when it has crashed


/me ought to see if we can get the automatic libvirt crash log to
include a stack trace, since the log messages are pretty useless
on their own.

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]