[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 0/4]use newer video device by -device in qemu commandline



On 12/10/2012 05:37 PM, Gerd Hoffmann wrote:
   Hi,

For backwards
compatibility, if a certain qemu version does not support one of the above
video device arguments to -device or even -device itself, the -vga will still
be used.
That will not work.  You must check the qemu version.  1.2+ is safe,
IIRC 1.1 will work too.

Technical background: '-device VGA' (+variants) exists for a looooooong
time, pretty much day one of the -device switch.  Actually using it did
not work though due to a nasty initialization order issue in qemu.  The
qemu memory api created by avi fixed it.

cheers,
   Gerd


     Okay,  if so, I prefer 1.2+ to ensure -device VGA work as expected.
A question here, all of these four vga device (VGA, cirrus-vga, vmware-svga, qxl-vga) has existed and been supported since 1.2 QEMU version, is it right? If so, libvirt
     doesn't need to check for them individually.

     Guannan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]