[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] No VirtualBox Driver




Hey Peter,

On Mon, Dec 17, 2012 at 12:42 PM, Peter Krempa <pkrempa redhat com> wrote:
On 12/17/12 07:40, Arslan Waqar wrote:
Hi all,

Hi Arslan,



I am new to the group and hence there might be a chance I might be
asking a simple question...

The thing is I compiled and installed libvirt from git. Then in my
terminal window I started virsh. It started. Then since I had Virtual
Box installed on my machine I ran "connect vbox:///session". Once I did
this I got two errors which said:
error: Failed to connect to the hypervisor
error: internal error unable to initialize VirtualBox driver API

What version of VirtualBox are you using? The support for Vbox 4.2 wasn't committed yet to the tree as it lacks feedback from the users. If you have VirtualBox 4.2 and are willing to test the patches for that it would be really helpful.




I am unable to resolve this issue...Any input is welcome!

Thanks!

--
Regards,
Arslan Waqar.


Peter



--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list



I do have Virtual Box 4.2 and I am willing to test ... So please do send me instructions on how to get going. If there are any specific use cases which need to be testet then do send them to me... (BTW, I have some important VMs on VirtualBox, should I be worried about them while testing?)

Also while installing I got the errors related to xhtml1-dtds ... I read quite a lot on it on http://www.redhat.com/archives/libvir-list/2009-November/msg00430.html and turns out this problem is not present in Fedora, it occurs in Ubuntu almost every time, because ubuntu does not have xhtml1-dtds package. Now, because of this will I face any problem? if so then what exactly, and how to solve it...Also is there a workaround for it...?

-- 
Regards,
Arslan Waqar.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]