[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: don't require avahi during install



See: https://bugzilla.redhat.com/show_bug.cgi?id=785269

The specfile requires avahi during install if libvirt was built with
avahi support, but there are many situations where it is undesirable
to install avahi due to security concerns. If we still Build-require
avahi-devel during the build, but don't require it at install time, it
will be used if present, and ignored if not.
---
 libvirt.spec.in |    3 ---
 1 files changed, 0 insertions(+), 3 deletions(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index f279d6d..dab9650 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -272,9 +272,6 @@ Requires: %{name}-client = %{version}-%{release}
 Requires: module-init-tools
 # for /sbin/ip & /sbin/tc
 Requires: iproute
-%if %{with_avahi}
-Requires: avahi
-%endif
 %endif
 %if %{with_network}
 Requires: dnsmasq >= 2.41
-- 
1.7.7.6


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]