[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Release of libvirt-0.9.10



On Tue, Feb 14, 2012 at 14:17:18 +0800, Jun Koi wrote:
> On Tue, Feb 14, 2012 at 1:15 PM, Daniel Veillard <veillard redhat com> wrote:
> >  As planned I made the release yesterday, it is tagged in git and
> > available at:
> >   ftp://libvirt.org/libvirt/
> > both as tarball and signed rpms for Fedora 16.
> 
> 
> i compiled this version on Ubuntu 10.4 (64bit), and got following errors:
...
>   CC     libvirt_driver_nwfilter_la-nwfilter_driver.lo
>   CC     libvirt_driver_nwfilter_la-nwfilter_gentech_driver.lo
>   CC     libvirt_driver_nwfilter_la-nwfilter_ebiptables_driver.lo
>   CC     libvirt_driver_nwfilter_la-nwfilter_learnipaddr.lo
>   CCLD   libvirt_driver_nwfilter.la
> libtool: link: require no space between `-L' and `/usr/lib'
> make[3]: *** [libvirt_driver_nwfilter.la] Error 1
> make[3]: Leaving directory `/home/jun/libvirt/libvirt-0.9.10/src'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/home/jun/libvirt/libvirt-0.9.10/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/jun/libvirt/libvirt-0.9.10'
> make: *** [all] Error 2

That's a frequent bug in pcap-config (coming from devel package for libpcap).
You can confirm it by running "pcap-config --libs"; it's buggy if there's a
space between -L and its argument.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]