[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-glib] Add gvir_domain_get_saved()



On Thu, Feb 16, 2012 at 11:01:45PM +0000, Daniel P. Berrange wrote:
> On Thu, Feb 16, 2012 at 10:16:11PM +0100, Christophe Fergeau wrote:
> > On Thu, Feb 16, 2012 at 09:51:34AM +0100, Christophe Fergeau wrote:
> > > On Thu, Feb 16, 2012 at 02:26:02AM +0200, Zeeshan Ali (Khattak) wrote:
> > > > + */
> > > > +gboolean gvir_domain_get_saved(GVirDomain *dom)
> > > 
> > > The naming needs to be more explicit, libvirt will suspend the domain after
> > > a call to virDomainSave or virDomainManagedSave, the current name only
> > > checks for the latter state. I'd go for
> > > gvir_domain_has_managed_save_image();
> > 
> > I see this patch has been pushed to master with this part unchanged and no
> > discussion whatsoever on the list, what happened there?
> 
> Oh, I ACK'd his new patch, without noticing your message in this
> thread.
> 
> I tend to agree with your suggestion to rename to
> 
>  gvir_domain_has_managed_save_image()

Actually, looking more closely at the API, virDomainManagedSave is wrapped
in gvir_domain_save, so gvir_domain_has_managed_save_image would be
inconsistent. However, _get_saved is a very confusing name for me,
gvir_domain_is_saved would fit much better, but we already had this
discussion...

Christophe

Attachment: pgpZNyCVbtKZX.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]