[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-glib] Add gvir_domain_get_saved()



On Fri, Feb 17, 2012 at 05:25:30PM +0200, Zeeshan Ali (Khattak) wrote:
> On Fri, Feb 17, 2012 at 5:18 PM, Christophe Fergeau <cfergeau redhat com> wrote:
> > On Fri, Feb 17, 2012 at 05:08:12PM +0200, Zeeshan Ali (Khattak) wrote:
> >> (We already discussed at length why this
> >> is needed and we are already doing it for other boolean getters so
> >> lets not have the discussion about this need, again).
> >
> > Actually this was discussed for libosinfo, not libvirt-glib, here is the
> > relevant email for those who were wondering about this discussion:
> >
> > https://www.redhat.com/archives/virt-tools-list/2011-November/msg00090.html
> 
> Ah ok but both libraries are meant to be first-class g* citizens and
> hence the same need to follow the usual conventions unless there is a
> compelling reason not to.

Making the C API as nice as possible to users is a very compelling reason
to me since we are writing a C library (emphasis on the "to me", I know we
disagree :)
This naming convention for getters is probably only useful for vala, I
think bindings for dynamic languages will introspect object properties at
runtime and use g_object_get(). So the decision to make is between making
the API nicer to read for C users VS making life slightly easier for some
bindings.
Would a Rename to: annotation help vala here? Or is there some annotation I
don't know of to mark property getters/setters?

Christophe

Attachment: pgpw9TmdsoRTa.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]