[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v2 0/4] Forbid migration with cache != none

On 02/22/2012 07:51 AM, Jiri Denemark wrote:
> I was also wondering if we should rather use more specific name for both
> the error code and flag, such as VIR(_ERR)?_MIGRATE_UNSAFE_CACHE
> (or ...UNSAFE_DISK) in the case we find other unsafe conditions...

I think that if we ever have sub-categories of unsafe operations, where
we want the user to pass varying flags to allow one but not the other
sub-category, then we could do:


that is, make the current generic name remain generic by having it cover
multiple bits, while the specific bits control the sub-options.  But for
now, I'm fine with just a single, shorter, name.

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]