[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Misleading error message when name is missing



On 02/23/2012 09:37 AM, Benjamin Cama wrote:
> Hi,
> 
> [forwarding this here from RH bug #796732]

Thanks for taking the time to contribute, and for putting up with our
split personality on bug reports to BZ vs. patches to the list :)

> 
> When creating a network (virsh net-create) with an erroneous XML
> containing an empty <name> element, the error message is misleading:
> 
> error: Failed to create network from foo.xml
> error: missing domain name information
> 
> It took me a bit of time to figure out that it was the *network* name
> that was missing (I generate this xml and didn't look at it, first).
> 
> I realized that the same message is used for missing name when creating
> a domain, network, or device node. Attached patch (warning: against a
> completly different git than yours, don't pay attention to wrong shas)
> thus make this message more generic.

ACK and pushed.  I also added you to AUTHORS; let me know if you need
any adjustments to a preferred spelling.

> PS: please Cc me, I'm not subscribed

That's list policy in general (hmm, another thing we should document on
our bug page - you don't have to be a subscriber to post a bug or patch,
because maintainers will reply-all).

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]