[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] hyperv connection



Dear Sir or Madam:

 

I am trying to connect hyper-v with libvirt0.9.8 with hyperv driver, but it always reply the follow error

 

virsh # connect hyperv://192.168.58.231:5985

Enter username for 192.168.58.231 [administrator]:

Enter administrator's password for 192.168.58.231:

2012-01-05 14:46:39.999+0000: 27155: info : libvirt version: 0.9.8

2012-01-05 14:46:39.999+0000: 27155: error : hypervDebugHandler:1308 : openwsman error: NULL response

error: Failed to connect to the hypervisor

error: internal error Transport error during enumeration: SSL connection error (16)

 

when I use the wsman to identify the hyper-v, it works, but I just can identify the hyper-v, not others.

 

[root localhost plugins]# wsman identify  -h 192.168.58.231 -u Administrator -p rd2 usi -d 6 -P 5985 -y basic

Jan  5 22:58:05  cl->authentication.verify_peer: 1

Jan  5 22:58:05  *****set post buf len = 238******

* About to connect() to 192.168.58.231 port 5985 (#0)

*   Trying 192.168.58.231... * connected

* Connected to 192.168.58.231 (192.168.58.231) port 5985 (#0)

> POST /wsman HTTP/1.1

Host: 192.168.58.231:5985

Accept: */*

Content-Type: application/soap+xml;charset=UTF-8

User-Agent: openwsman 2.2.3

Content-Length: 238

 

< HTTP/1.1 401

< Server: Microsoft-HTTPAPI/2.0

* gss_init_sec_context() failed: : Credentials cache file '/tmp/krb5cc_0' not found< WWW-Authenticate: Negotiate

< WWW-Authenticate: Basic realm="WSMAN"

< WWW-Authenticate: CredSSP

< Date: Fri, 06 Jan 2012 06:56:10 GMT

< Connection: close

< Content-Length: 0

<

* Closing connection #0

Jan  5 22:58:05  Basic authentication is used

* About to connect() to 192.168.58.231 port 5985 (#0)

*   Trying 192.168.58.231... * connected

* Connected to 192.168.58.231 (192.168.58.231) port 5985 (#0)

* Server auth using Basic with user 'Administrator'

> POST /wsman HTTP/1.1

Authorization: Basic QWRtaW5pc3RyYXRvcjpyZDJAdXNp

Host: 192.168.58.231:5985

Accept: */*

Content-Type: application/soap+xml;charset=UTF-8

User-Agent: openwsman 2.2.3

Content-Length: 238

 

< HTTP/1.1 200

< Content-Type: application/soap+xml;charset=UTF-8

< Server: Microsoft-HTTPAPI/2.0

< Date: Fri, 06 Jan 2012 06:56:10 GMT

< Content-Length: 490

<

Jan  5 22:58:05  write_handler: recieved 490 bytes, all = 490

 

* Connection #0 to host 192.168.58.231 left intact

Jan  5 22:58:05  curl error code: 0.

Jan  5 22:58:05  cl->response_code: 200.

Jan  5 22:58:05  cl->last_error code: 0.

<?xml version="1.0" encoding="UTF-8"?>

<s:Envelope xmlns:s="http://www.w3.org/2003/05/soap-envelope" xml:lang="en-US">

  <s:Header/>

  <s:Body>

    <wsmid:IdentifyResponse xmlns:wsmid="http://schemas.dmtf.org/wbem/wsman/identity/1/wsmanidentity.xsd">

      <wsmid:ProtocolVersion>http://schemas.dmtf.org/wbem/wsman/1/wsman.xsd</wsmid:ProtocolVersion>

      <wsmid:ProductVendor>Microsoft Corporation</wsmid:ProductVendor>

      <wsmid:ProductVersion>OS: 6.1.7600 SP: 0.0 Stack: 2.0</wsmid:ProductVersion>

    </wsmid:IdentifyResponse>

  </s:Body>

</s:Envelope>

* Closing connection #0

[root localhost plugins]#

 

I work on this for a long time, but I still fail at the connection. Hope you can help.

Thanks,

Andy Li   MFG Software Developer
Department of Storage Products R&D, SCS
Universal Scientific Industrial (Shanghai) Co., Ltd
421 Lishizhen Rd, Pudong New Area, Shanghai,P.R. China, 201203
Tel : +86 -21-5896 6996 ext. 81453
Fax : +86 -21-5080 4268

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]