[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: fix bootstrap on fresh clone



Commit 29db7a0 picked up a gnulib bug, where a change in
bootstrap meant that it would fail to run libtoolize on
projects, like libvirt, that used the older spelling
AM_PROG_LIBTOOL instead of LT_INIT for the sake of
building on RHEL 5.  Now that gnulib is fixed, we should
pick up that fix.

* .gnulib: Update to latest, for bootstrap fix.
* bootstrap: Resync from gnulib.
---

Tested on a fresh clone of libvirt.git in RHEL 5, and pushing under
the build-breaker rule.

* .gnulib 980097f...dd6b2d7 (8):
  > bootstrap: cater to autoconf 2.59
  > bootstrap: properly check for libtool
  > Improve support for MSVC 9.
  > gnupload: we hold the master copy of this script now
  > Fix module 'random'.
  > Tests for module 'random'.
  > New module 'random'.
  > autoupdate

 .gnulib   |    2 +-
 bootstrap |   12 ++++++++----
 2 files changed, 9 insertions(+), 5 deletions(-)

diff --git a/.gnulib b/.gnulib
index 980097f..dd6b2d7 160000
--- a/.gnulib
+++ b/.gnulib
@@ -1 +1 @@
-Subproject commit 980097f8eca9e08feb2073d06179f53ba46b805e
+Subproject commit dd6b2d751b3c6ad417f6a4c48f2adb9d27cc59d2
diff --git a/bootstrap b/bootstrap
index 66da981..2a409fc 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Print a version string.
-scriptversion=2012-01-06.07; # UTC
+scriptversion=2012-01-16.17; # UTC

 # Bootstrap this package from checked-out sources.

@@ -758,7 +758,7 @@ fi
 # Autoreconf runs aclocal before libtoolize, which causes spurious
 # warnings if the initial aclocal is confused by the libtoolized
 # (or worse out-of-date) macro directory.
-if grep '^[    ]*LT_INIT' configure.ac >/dev/null; then
+if test $use_libtool = 1; then
   echo "running: $LIBTOOLIZE --copy --install"
   $LIBTOOLIZE --copy --install
 fi
@@ -820,10 +820,14 @@ find "$m4_base" "$source_base" \
   -type l -xtype l -delete > /dev/null 2>&1

 # Tell autoreconf not to invoke autopoint or libtoolize; they were run above.
+no_recursive=
+case $($AUTORECONF --help) in
+  *--no-recursive*) no_recursive=--no-recursive;;
+esac
 echo "running: AUTOPOINT=true LIBTOOLIZE=true " \
-    "$AUTORECONF --verbose --install --no-recursive -I $m4_base $ACLOCAL_FLAGS"
+    "$AUTORECONF --verbose --install $no_recursive -I $m4_base $ACLOCAL_FLAGS"
 AUTOPOINT=true LIBTOOLIZE=true \
-    $AUTORECONF --verbose --install --no-recursive -I $m4_base $ACLOCAL_FLAGS \
+    $AUTORECONF --verbose --install $no_recursive -I $m4_base $ACLOCAL_FLAGS \
   || exit 1

 # Get some extra files from gnulib, overriding existing files.
-- 
1.7.7.5


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]