[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-glib] Fix compilation with glib 2.22



On Wed, Jan 18, 2012 at 12:14:46PM +0100, Christophe Fergeau wrote:
> This commit raises glib required version to 2.22 or newer, adds a few
> missing functions to libvirt-gobject-compat.h and includes it in the
> files using these functions.
> ---
>  configure.ac                                    |    2 +-
>  libvirt-gobject/Makefile.am                     |    1 +
>  libvirt-gobject/libvirt-gobject-compat.c        |  104 +++++++++++++++++++++++
>  libvirt-gobject/libvirt-gobject-compat.h        |   30 +++++++
>  libvirt-gobject/libvirt-gobject-domain-device.c |    1 +
>  libvirt-gobject/libvirt-gobject-input-stream.c  |    1 +
>  libvirt-gobject/libvirt-gobject-interface.c     |    1 +
>  libvirt-gobject/libvirt-gobject-output-stream.c |    1 +
>  8 files changed, 140 insertions(+), 1 deletions(-)
>  create mode 100644 libvirt-gobject/libvirt-gobject-compat.c

ACK

> 
> diff --git a/configure.ac b/configure.ac
> index 79a6eff..9f550ae 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -10,7 +10,7 @@ AC_CANONICAL_HOST
>  AM_SILENT_RULES([yes])
>  
>  LIBVIRT_REQUIRED=0.9.8
> -GLIB2_REQUIRED=2.10.0
> +GLIB2_REQUIRED=2.22.0
>  GOBJECT2_REQUIRED=2.10.0
>  GIO_REQUIRED=2.10.0
>  GOBJECT_INTROSPECTION_REQUIRED=0.10.8

Can you also make the same change to libvirt-glib.spec.in for the RPM

Regards,
Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]