[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Can't compile libvirt 0.9.9 (complains about apparmor)



Hi,

I need to compile libvirt 0.9.9 to work with qemu-kvm 1.0.
I use to compile libvirt without apparmor or selinux, but this time, with the newer version, it seems that i can't compile with the following options:

./configure --disable-rpath --with-qemu=yes --with-qemu-user=libvirt-qemu --with-qemu-group=kvm --with-init-script=none --without-xen-inotify --without-uml --without-vmware --without-libssh2 --without-phyp --without-xenapi --without-libxl --without-esx --without-hyperv --without-test --without-remote --without-sasl --without-yajl --without-sanlock --without-polkit --without-avahi --without-audit --without-dtrace --without-numactl --without-capng --without-network --without-netcf --without-secrets --without-storage-lvm --without-storage-dir --without-storage-fs --without-storage-iscsi --without-storage-scsi --without-storage-mpath --without-storage-disk --without-python --without-driver-modules --without-hal --without-udev --without-libblkid --without-virtualport --without-macvtap --enable-debug=n --without-xen --without-vbox --without-lxc --without-openvz --with-driver-modules=no --without-apparmor --without-secdriver-apparmor --without-selinux --without-secdriver-selinux


Relevant error is :
configure:54338: error: You must install the AppArmor development package in order to compile libvirt

Note that, if i compile with the option "with-apparmor", configure works fine, and i haven't any errors.

Is it possible to compile libvirt without apparmor?

Best regards.

--
Jean-Philippe Menil - Pôle réseau Service IRTS
DSI Université de Nantes
jean-philippe menil univ-nantes fr
Tel : 02.53.48.49.27 - Fax : 02.53.48.49.09


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]