[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt can't get capablities



On 2012年07月02日 17:47, Li Zhang wrote:

Hi,

I have suffered several times on both x86 machine and power machine.

When we want to use libvirt to create on VMs, it reports "unknown OS
type hvm".

We can't get <guest> capabilities.

The log is as the following(log_level=1):

2003-01-02 01:21:39.895+0000: 12214: error : virDomainDefParseXML:8491 :
unknown OS type hvm
2003-01-02 01:21:39.896+0000: 12214: error : virDomainDefParseXML:8491 :
unknown OS type hvm
2003-01-02 01:22:00.135+0000: 12207: error :
qemuCapsComputeCmdFlags:1218 : unsupported configuration: this qemu
binary requires libvirt to be compiled with yajl

You need to build the pkg with yajl-devel.

I'm wondering if we should force to require yajl-devel if build with
"with-qemu", as without yajl-devel, it can't do much work with new
qemu now.

Regards.
Osier



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]